The Issuer of MasterCard debit-cards in Iceland is responding slowly resulting in MasterCard
Incident Report for Rapyd Services
Resolved
This incident has been resolved by the issuer.
Posted Oct 25, 2021 - 17:58 UTC
Monitoring
The Issuer of MasterCard debit-cards in Iceland is responding slowly resulting in MasterCard Debitcards not working for some cardholder and Merchants.
Posted Oct 25, 2021 - 17:50 UTC