Mastercard disruption impacting SecureCode (3DS) transactions
Incident Report for Rapyd Services
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 09:35 UTC
Monitoring
The situation seems to be resolved, we are observing transactions flowing normally since around 9:10 GMT.
Posted Nov 30, 2022 - 09:22 UTC
Identified
There is an ongoing disruption in processing secure payments (3DS) through Mastercard. This is an external issue but we are monitoring the situation closely.
Posted Nov 30, 2022 - 09:07 UTC
This incident affected: Fintechs & Merchants - Acquiring Backend Services (Secure Authentication - 3D Secure Services).