POS Terminals - degraded service
Incident Report for Rapyd Services
Resolved
PAX POS are now working normally on 4G.

This incident is considered resolved.
Posted Nov 24, 2022 - 02:39 UTC
Update
The incident is still ongoing but our telco provider is working on a fix. Please see below for workaround that is available for PAX A920 terminals.
Posted Nov 23, 2022 - 07:07 UTC
Update
The incident is still ongoing. We want to point out that the following workaround is possible for PAX A920 terminals when a WiFi/hotspot is available:
Select the 3 lines in the top right corner
Select WiFi Settings
Find the WiFi that you want to connect to and enter the WiFi password
Posted Nov 22, 2022 - 23:22 UTC
Update
Vodafone has identified a problem and is working on the issue.
Posted Nov 22, 2022 - 22:56 UTC
Identified
The incident is limited to terminals connecting through 3G/4G. We are investigating the issue with our provider. A temporary workaround is to connect through WIFI/hotspot where that is possible.
Posted Nov 22, 2022 - 22:17 UTC
Investigating
There are connection issues with POS terminals in Iceland connecting through 4G. Updates will follow.
Posted Nov 22, 2022 - 21:57 UTC
This incident affected: Merchant - POS Terminals (Merchant - POS Terminals).