Investigating Interruptions in Issuing Authorization System
Incident Report for Rapyd Services
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 13:26 UTC
Investigating
We are investigating issues in our authorization system affecting some debit and credit cards. Our team is working on a solution. Updates will follow.
Posted Jan 13, 2022 - 13:16 UTC
This incident affected: Cardholder - Issuing Authorisation.