Degraded Network Performance
Incident Report for Rapyd Services
Resolved
The incident is now resolved. The outage impacted several web systems for approximately 19 minutes between 10:23 and 10:42 but authorisation systems seem to have remained operational.
Posted May 09, 2023 - 11:08 UTC
Monitoring
The issue seems to be resolved. We are monitoring the situation and will update soon. Various web systems were impacted.
Posted May 09, 2023 - 10:46 UTC
Update
We are continuing to investigate this issue.
Posted May 09, 2023 - 10:40 UTC
Investigating
We are experiencing degraded network performance. This might affect some services. Updates will follow.
Posted May 09, 2023 - 10:34 UTC
This incident affected: Customer Support (Telephony Service in Iceland) and Merchant - Backoffice Saga.