Investigating degraded service in the Acquiring Authorization System

Incident Report for Rapyd Services

Resolved

We are investigating some issues in our Acquiring authorization system. These issues might affecting some merchants. Updates will follow.
Posted Feb 06, 2025 - 11:17 UTC

Investigating

We are investigating some issues in our Acquiring authorization system. These issues might affecting some merchants. Updates will follow.
Posted Feb 06, 2025 - 11:17 UTC
This incident affected: Merchant - Acquiring Authorisation.