Network incident investigating
Incident Report for Rapyd Services
Resolved
This incident has been resolved.
Posted Oct 24, 2021 - 13:20 UTC
Monitoring
There was an 11 minute interruption earlier. Systems are stable now and we are monitoring.
Posted Oct 24, 2021 - 13:11 UTC
Update
This seems to be due to a third party network interruption. Investigation ongoing.
Posted Oct 24, 2021 - 13:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 24, 2021 - 12:57 UTC
This incident affected: Customer Support (Telephony Service in Iceland).