Issuing Webservices Errors

Incident Report for Rapyd Services

Resolved

We are investigating some issues in our Acquiring authorization system. These issues might affecting some merchants. Updates will follow.
Posted Feb 20, 2026 - 18:35 UTC

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Feb 20, 2026 - 18:35 UTC
This incident affected: Fintechs & Banks - Issuing Backend Services (Issuing Webservices for ServiceProviders).