MasterCard Payment degradation (limited affect)
Incident Report for Rapyd Services
Resolved
Resolved :-)
Posted Oct 13, 2021 - 20:04 UTC
Identified
We are currently seeing intermittent performance issues with our 3D Secure provider for MasterCard payments which can result in consumers not being able to complete their authentication. Affecting a small number of MasterCard card holders.
Posted Oct 13, 2021 - 18:06 UTC
This incident affected: Fintechs & Banks - Issuing Backend Services (E-Commerce: 3D Secure Services).