Merchant Portal SAGA Degraded Functionality
Incident Report for Rapyd Services
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 17:13 UTC
Monitoring
Services have recovered and we are monitoring the situation.
Posted Jul 25, 2024 - 16:49 UTC
Identified
We are still working to resolve the issue. Updates will follow.
Posted Jul 25, 2024 - 15:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results. There may be some minutes until we are fully operational again.
Posted Jul 25, 2024 - 14:41 UTC
Investigating
Our merchant portal Saga is experiencing some issues leading to degraded or limited functionality. Our team is working to resolve the issue. Updates will follow.
Posted Jul 25, 2024 - 14:28 UTC
This incident affected: Merchant - Backoffice Saga.