Issuing Service degraded on Service WebSites
Incident Report for Rapyd Services
Resolved
This incident has been resolved.
Posted May 17, 2023 - 14:09 UTC
Investigating
We're experiencing an elevated level of website errors and are investigating. Updates will follow.
Posted May 17, 2023 - 14:01 UTC
This incident affected: Fintechs & Banks - Issuing Backend Services (Kortaumsóknavefur - kortaumsokn.valitor.is, Innkaupavefur - innkaupavefur.valitor.is, Endurkröfuvefur - endurkrafa.valitor.is).