Merchant Portal Saga - Degraded Functionality
Incident Report for Rapyd Services
Resolved
This incident has been resolved.
Posted May 05, 2023 - 18:40 UTC
Investigating
Our merchant portal Saga is experiencing some issues leading to degraded or limited functionality. Our team is working on the issue. Updates will follow.
Posted May 05, 2023 - 15:32 UTC
This incident affected: Merchant - Backoffice Saga.