Minor disturbance related to yesterday's incident
Incident Report for Rapyd Services
Resolved
Services are operational.
Posted Nov 17, 2023 - 11:19 UTC
Identified
We are getting notifications of interruptions to some clients that seem related to the resolution of yesterday's incident.
Posted Nov 17, 2023 - 10:03 UTC
This incident affected: Merchant - POS Terminals (Merchant - POS Terminals, Ingenico UK/I, Ingenico Iceland, PAX UK/I, PAX Iceland).